Download a Supported Web Browser

The Provider Portal application is built on advanced modern technologies and does not support old Web browsers. It is strongly recommended that you use a supported Web browser to minimize potential security risks and ensure the best possible portal experience. If you use an unsupported Web browser some portal features may not work correctly. Supported Web browsers are dependent on application mode, device, and operating system. See system requirements for New View and Classic View for more information. 

Note: The Provider Portal application does not support functions provided by your Web browser context menu such as print, select all, and copy.

Supported Web Browsers

Microsoft Edge
Microsoft Internet Explorer 11
Google Chrome
Mozilla Firefox
- Apple Safari 

Microsoft Edge

Supported in: portal v4.4.2 and later; New View only
Download Microsoft Edge 

Microsoft Internet Explorer 11

Supported in: Classic View (in browser compatibility view); New View
Download Internet Explorer 11

Google Chrome

Supported in: Classic View; New View
Download Chrome

Mozilla Firefox

Supported in: Classic View; New View
Download Firefox

Apple Safari

Supported in: New View only and only on Apple devices
Keep Safari up to date by keeping OS X and iOS software up to date:

Copyright Cerner Corporation. All rights reserved.